恢复安装Exchange 2003后无法启动Exchange System Attendant服务
【问题描述】
===========================
客户Exchange Server 2003服务器因为硬件的故障造成无法开机。只好尝试使用灾难恢复的模式(使用原机器名)在新的硬件上安装Exchange Server 2003。但安装好后发现Exchange System Attendant服务无法启动,并报以下的错误:
事件来源: MSExchangeSA
事件种类: 常规
事件 ID: 9022
日期: 2013-11-19
事件: 13:01:03
用户: N/A
计算机: EXSERVER
描述:
Microsoft Exchange System Attendant 在处理 Exchange 服务器“EXSERVER”的安全数据时遇到错误。
事件来源: MSExchangeSA
事件种类: 常规
事件 ID: 9021
日期: 2013-11-19
事件: 13:01:03
用户: N/A
计算机: EXSERVER
描述:
Microsoft Exchange System Attendant 已为 Exchange 服务器“EXSERVER”生成了新的安全密钥。必须使用“Exchange 系统管理”管理单元重新输入此服务器所需的所有密码。
事件来源: MSExchangeSA
事件种类: 常规
事件 ID: 9149
日期: 2013-11-19
事件: 13:01:03
用户: N/A
计算机: EXSERVER
描述:
Microsoft Exchange System Attendant 启动 Exchange 服务器“EXSERVER”失败。错误代码“0x80070005”。
事件来源: MSExchangeSA
事件种类: 常规
事件 ID: 1005
日期: 2013-11-19
事件: 13:01:03
用户: N/A
计算机: EXSERVER
描述:
出现意外错误 拒绝访问。 设备: LDAP Provider ID 号: 80070005 Microsoft Exchange System Attendant 。
【问题原因】
===========================
经过分析,得知客户在重新安装Exchange服务器时,在AD中先删除了原有的Exchange机器,然后再加入域。并不是正常的使用“重设帐户”的方式。
【解决方法】
===========================
使用ADSIEDIT工具,将Exchange Server 2003机器的计算机帐户设置“完全访问”的权限。方法如下:
1.打开ADSIEDIT工具(PS:如果没有安装,请从 Windows Server的安装光盘下 Support\Tools进行安装)
2.定位到Configuration->CN=Configuration,DC=domain,DC=com->CN=Services->CN=Microsoft Exchange->CN=OrganizationName->右键属性->选择“安全”选项卡->添加-》增加Exchange的计算机名比如“ExServer”,并给于“完全访问”权限
3.定位到Configuration->CN=Configuration,DC=domain,DC=com->CN=Services->CN=Microsoft Exchange->CN=OrganizationName->CN=Administrative Groups->CN=AdministrativeGroupName->CN=Servers>右键属性->选择“安全”选项卡->添加-》增加Exchange的计算机名比如“ExServer”,并给于“完全访问”权限
4.定位到CN=Configuration->CN=Configuration,DC=domain,DC=com->CN=Services->CN=Microsoft Exchange->CN=OrganizationName->CN=Administrative Groups->CN=AdministrativeGroupName->CN=Servers>CN=InformationStore-》右键属性->选择“安全”选项卡->添加-》增加Exchange的计算机名比如“ExServer”,并给于“完全访问”权限
5.定位到CN=Configuration->CN=Configuration,DC=domain,DC=com->CN=Services->CN=Microsoft Exchange->CN=OrganizationName->CN=Administrative Groups->CN=AdministrativeGroupName->CN=Servers>CN=Microsoft MTA-》右键属性->选择“安全”选项卡->添加-》增加Exchange的计算机名比如“ExServer”,并给于“完全访问”权限
6.定位到CN=Configuration->CN=Configuration,DC=domain,DC=com->CN=Services->CN=Microsoft Exchange->CN=OrganizationName->CN=Administrative Groups->CN=AdministrativeGroupName->CN=Servers>CN=Microsoft System Attendant-》右键属性->选择“安全”选项卡->添加-》增加Exchange的计算机名比如“ExServer”,并给于“完全访问”权限-》右键属性->选择“安全”选项卡->添加-》增加Exchange的计算机名比如“ExServer”,并给于“完全访问”权限
7.定位到CN=Configuration->CN=Configuration,DC=domain,DC=com->CN=Services->CN=Microsoft Exchange->CN=OrganizationName->CN=Administrative Groups->CN=AdministrativeGroupName->CN=Servers>CN=Protocols-》右键属性->选择“安全”选项卡->添加-》增加Exchange的计算机名比如“ExServer”,并给于“完全访问”权限-》右键属性->选择“安全”选项卡->添加-》增加Exchange的计算机名比如“ExServer”,并给于“完全访问”权限
8.关闭 ADSI 工具
9.等待AD复制成功
10.重启Exchange服务器,检查服务是否启动成功。
【参考信息】
===========================
http://support.microsoft.com/kb/325674/en-us
http://support.microsoft.com/kb/297295/en-us
历史评论
暂无保留的历史评论。
评论为旧站历史记录,本站不再接受新评论。